yum update で,remi の WordPress 5.5.1-1 から 5.5.1-2 へのアップデートに失敗していた.正しいやり方なのかどうかわからないけれども,私は次のようにして解決しました.

Pocket

 

いつもどおりに yum update をかけたら,WordPress のアップデートが失敗していた.
remi リポジトリの
wordpress.noarch 0:5.5.1-1.el7.remi から
wordpress.noarch 0:5.5.1-2.el7.remi へのアップデート.

調べてみると,wp-includes/PHPMailer/ を展開するところで失敗していた.
5.5.1-1 のほうは,PHPMailer/ ディレクトリ実体で,
5.5.1-2 のほうは,/usr/share/php/PHPMailer/PHPMailer6/ へのシンボリックリンクになっていて,それで展開に失敗しているっぽい.
これって,remi のパッケージの作り方がよくないんじゃないかなぁ?

 

どういうふうにして解決するのが正しいやり方なのかわからないけれども,私は,

mv wp-includes/PHPMailer wp-includes/PHPMailer.old

することで,yum update に成功するようになりました.
yum update に成功したら,wp-includes/PHPMailer.old をどこかに避けておけば,今後に影響ないのではないかと思う.

 

 
 
 
 
==

Similar Posts:

Pocket

コメントを残す

メールアドレスが公開されることはありません。

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください